侵权投诉

订阅
纠错
加入自媒体

RFC3918聚合组播吞吐量测试——网络测试仪实操

一、简介

1.RFC3918简介

历史

· 在1999年3月成为正式标准

功能

· 评测网络互连设备或网络系统的性能

· 网络设备: 交换机,路由器…

内容

· 定义了一整套测试方法,为不同厂家的设备/系统提供了统一的评估标准和报告格式

相关文档

· RFC 2432, Terminology for IP Multicast Benchmarking

· RFC 3918, Methodology for IP Multicast Benchmarking

2.RFC3918 测试内容

混合吞吐量测试

· Mixed Class Throughput Test

· 确定向一定数量的接口同时发送单播和组播时,DUT/SUT的吞吐量

组转发矩阵测试

· Scaled Group Forwarding Matrix Test

· 确定DUT/SUT在一定数量端口加入不同数量的组播组时的转发率

聚合组播吞吐量测试

· Aggregated Multicast Throughput Test

· 确定DUT/SUT加入相同组播组的多个测试端口在不丢包的情况下的最大转发速率

组播转发时延测试

· Multicast Forwarding Latency Test

· 得到从DUT/SUT一个入端口到多个出端口的一组时延数据

组播组容量测试

· Multicast Group Capacity Test

· 确定在DUT/SUT能够正确转发数据包到注册在该DUT/SUT的组播组环境下,DUT/SUT能够支持的最大的组播组数量

3.聚合组播吞吐量测试

定义

· 吞吐量(Throughput):没有丢包情况下能够转发的最大速率

测试目的

· 确定DUT/SUT加入相同组播组的多个测试端口在不丢包的情况下的最大转发速率

· 衡量DUT的组播复制能力,和组转发矩阵的测试在不断增加组的数量相比,组播总体吞吐量的测试是在不断的增加出接口的数量

测试过程

· 报文数量和预期接收到的报文数量相等,则增加速率继续测试;如果不相等,则减小速率继续测试

二、测试说明

聚合组播吞吐量  测试拓扑

拓扑说明

· DUT是一台三层交换机

· 测试仪的四个端口和DUT相连,一个模拟组播源,两个模拟组成员,一个模拟监听端口

目的

· 测试DUT加入相同组播组的多个测试端口在不丢包情况下的最大转发速率

image.png

接下来,让我们使用信而泰BigTao-V网络测试仪进行聚合组播吞吐量测试

image.png

image.png

DUT配置

#-

vlan batch 500 600 700 800

#-

multicast routing-enable

#-

interface Vlanif500

ip address 210.10.10.1 255.255.255.0

pim sm

#-

interface Vlanif600

ip address 210.10.20.1 255.255.255.0

igmp enable

#-

interface Vlanif700

ip address 210.10.30.1 255.255.255.0

igmp enable

#-

interface Vlanif800

ip address 210.10.40.1 255.255.255.0

#-

#-

interface GigabitEthernet0/0/21

port link-type access

port default vlan 500

#-

interface GigabitEthernet0/0/22

port link-type access

port default vlan 600

#-

interface GigabitEthernet0/0/23

port link-type access

port default vlan 700

#-

interface GigabitEthernet0/0/24

port link-type access

port default vlan 800

#-

三、测试配置

准备工作: 添加机框

image.png

准备工作: 预约端口

image.png

选择向导

选择RFC3918向导

image.png

1  2  3  4  下一页>  
声明: 本文由入驻维科号的作者撰写,观点仅代表作者本人,不代表OFweek立场。如有侵权或其他问题,请联系举报。

发表评论

0条评论,0人参与

请输入评论内容...

请输入评论/评论长度6~500个字

您提交的评论过于频繁,请输入验证码继续

暂无评论

暂无评论

文章纠错
x
*文字标题:
*纠错内容:
联系邮箱:
*验 证 码:

粤公网安备 44030502002758号